Support System Email Issue
Incident Report for UK Servers Status
Resolved
This incident has been resolved.
Posted Oct 02, 2022 - 17:39 BST
Update
This issue has been resolved and our helpdesk is now importing emails as expected.
Posted Oct 02, 2022 - 11:57 BST
Investigating
We are currently experiencing an issue with emails imported into our helpdesk.

Customers are requested to login at https://control.ukservers.com and submit/reply to any support requests via the portal until this issue is resolved.
Posted Oct 02, 2022 - 08:49 BST