Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 14, 2025 - 11:00 BST
Scheduled
In keeping with the manufacturer's recommendation we will be carrying out scheduled maintenance on the UPS systems in Data Hall 1 at our Coventry datacentre.
There is no planned service impact, this is an advisory notice as there will be reduced UPS resilience whilst the maintenance is being carried out. Power will remain unaffected to customer racks, but with reduced resiliency during the maintenance period.
The maintenance will be completed by a specialist 3rd party and the UPS units will be fully tested prior to being returned to normal service. Complete power protection will be restored upon completion of the UPS maintenance.
Posted Apr 10, 2025 - 21:38 BST
This scheduled maintenance affected: Coventry (DH1).