Email Support Issue
Incident Report for UKDSL
Resolved
This issue has now been resolved, customers can now submit any requests to us again via email, if you have sent a request via email within the last 24-36 hours that has not been replied to as yet then please re-send this request.
Posted May 31, 2020 - 16:41 UTC
Investigating
We are currently experiencing an issue with customer's emails not being parsed into our helpdesk.

We ask any customers to please login and submit a ticket at https://control.ukservers.com rather than by email whilst we are looking into this issue.
Posted May 31, 2020 - 13:39 UTC
This incident affected: Coventry DH1, Coventry DH2, Telehouse East (THE), Telehouse North (THN), Telehouse West (THW), Sovereign House (SOV), Pulsant (Maidenhead) 1, and Pulsant (Maidenhead) 2.