Power Incident at Coventry Datacentre
Incident Report for UK Servers Status
Resolved
Incoming power to the site has been stable for the last 48 hours, this incident is now being closed.
Posted May 26, 2020 - 14:37 BST
Monitoring
Mains power has been restored to this site, we are awaiting to hear an update from Western Power however this site is no longer deemed at risk.
Posted May 24, 2020 - 13:47 BST
Investigating
Our Coventry datacentre site is currently running from generator power in response to a mains power failure.

Further information will be provided shortly.
Posted May 24, 2020 - 13:20 BST
This incident affected: Coventry (DH1) and Coventry (DH2).