mitigation has been put in place and SMTP / Inbound email processing is now working again as it should.
Posted Mar 17, 2025 - 16:13 GMT
Investigating
We are currently experiencing an issue with emails being imported into our helpdesk system. Customers are asked to login to their heldpesk to open a ticket with any critical issues they might be experiencing.
Posted Mar 17, 2025 - 11:40 GMT
This incident affected: Coventry - Continuity House (205/DC3), Coventry (DH1), Coventry (DH2), Telehouse East (THE), Telehouse North (THN), Telehouse West (THW), Pulsant 2 (MHD), and Equinix MA1 (MCR).