Network Incident - Coventry Datacentre - Packet Loss

Incident Report for UK Servers Status

Resolved

This issue has been resolved since 11:54 AM UTC+1.
The faulty link remains isolated and will be replaced at a later date with prior isolated testing, with a maintenance window scheduled to bring it back into service.
Posted Apr 16, 2025 - 18:05 BST

Monitoring

A faulty link between two core routers in Coventry has been isolated and the connectivity has stabilized.
Customers experiencing issues are recommended to open a support ticket.
Posted Apr 16, 2025 - 12:03 BST

Investigating

We are currently investigating a network issue causing some packet loss to customers at our Coventry datacentre

Our network engineers are diagnosing the problem and further updates should follow.

Dedicated or shared colocation customers may experience packet loss, increased latency or interruptions in connection whilst this is being resolved.
Posted Apr 16, 2025 - 11:55 BST
This incident affected: Coventry - Continuity House (205/DC3), Coventry (DH1), and Coventry (DH2).